International Space Station Live

Browser Requirements

This site and 3D plugins work best on PCs and Macs using Firefox 4 (and higher), Internet Explorer 8 (and higher), or Safari (5 and higher) web browsers. This site requires JavaScript and scripting enabled in your browser. For best results, minimize simultaneous use of other resource intensive applications including multiple open tabs on your web browser.

firefox IE8+ Safari

For 3D interactive features, please ensure you have the latest version of the Unity web player installed.

Unity Player Download

Disclaimer: From time to time, telemetry data connection may be down for updates.

Tietronix